Topic: Game Crash

I just activated the /cl_renderer rend2 command and restarted the game, but it crash every time I tried to open it.
Sorry for my bad English

Re: Game Crash

What video card / drivers do you have? It needs to at least have OpenGL2/3 support as a minimum.

Re: Game Crash

I have an intel celeron integrated graphics card with OpenGL 3.1

Re: Game Crash

Can you post the crashlog.txt?

It should be in the coop folder in Documents/MyDocuments on Windows if that's what you're using

Re: Game Crash

Doesn't appear the log, every time I open RTCWCoop.x86.exe it ask me if i want to try it with the safe graphic settings and the intro start, but when I skip it (or not) it crash.

There is a command to get it back the normal renderer?

Re: Game Crash

add +set cl_renderer opengl1 on the command line (in your shortcut)

or just open your and change the cl_renderer value from rend2 to opengl1

Re: Game Crash

fretn wrote:

add +set cl_renderer opengl1 on the command line (in your shortcut)

or just open your and change the cl_renderer value from rend2 to opengl1

Thanks, it works!

I check the log again and this appears:

/set cl_renderer rend2
cl_renderer will be changed upon restarting.
Hunk_Clear: reset the hunk ok
RE_Shutdown( 1 )
----- Initializing Renderer ----
Trying to load "renderer_coop_rend2_x86.dll" from "C:\Program Files\Steam\SteamApps\common\Return to Castle Wolfenstein"...
----- R_Init -----S

I add more about my pc and graphic card:

MS Windows 7

Intel Celeron CPU G440 1.60Ghz

DirectX 9.0c - 10.1

OpenGL 3.1

Vertex Shader 4.1 - Pixel Shader 4.1

8 (edited by profitgamers 2014-06-18 13:38:56)

Re: Game Crash

I Had quite another problem which caused game crash at start

My graphics settings config (WolfConfig.Coop) I used with v0.9.5 Patch 1 caused RTCWCoop.x86.exe to crash while I was launching the game.

I deleted the old cfg and now setting up a new one according to the settings I used in old one (WolfConfig.Coop) .

Is there any shortcut command that makes game use NO INTRO at start?

Are all the cfg must be stored only at My Documents/RTCWCOOP/CoopMain ?

I have


And how can I play my demos form 0.9.5 ?

For examle : Dam1.dm_10 < this is the format 0.9.5 used

1.0.0 says that it cant load Dam1.dm_57 !?

So I renamed it to Dam1.dm_57 and now it says

ERROR: Client/Server game mismatch: main-1/baseq3-1

0V3RDR!VE !!!!

Re: Game Crash

no intro: set com_introplayed 1
you cannot play demos from 0.9.5 as far as I know

10 (edited by nate 2014-06-18 15:29:01)

Re: Game Crash

Try playing demos on mp. As far as extension goes, just make sure it matches the game protocol..rtcw 1.0 = 57, 1.3 = 58, 1.4 = 60....use 1.0 for testing otherwise you'll need to edit pak0 check in 1.4 binary as it prevents loading of SP maps.

11 (edited by profitgamers 2014-06-19 15:50:03)

Re: Game Crash

Unfortuntely , it doesnt help . CL_BadServer_Command or something . Tried SP and MP.

Is there any chance that demo compability with old versions will be available in future ?

And Mouse sensitivity in menu . is there any command?

0V3RDR!VE !!!!

Re: Game Crash

The coop demo's are not compatible with mp or sp

About ui mouse speed: need to look it up. I'm on my phone now

Re: Game Crash

First....Demo playback NEVER worked in SP which is what the code is mainly based on.

Aside from that, the original SP basegame was "baseq3" as opposed to "main" which is what MP used.

Also some changes were made to the game code to make demos work in the first place.

So the demo playback in the new engine will probably never work with demos made in prior versions for those reasons.

You might be able to get somewhere if you add +set com_basegame baseq3 to the commandline, but I wouldn't count on it.